summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest5
-rw-r--r--dev-python/platformdirs/platformdirs-2.0.2.ebuild24
-rw-r--r--dev-python/platformdirs/platformdirs-2.2.0.ebuild30
-rw-r--r--dev-python/platformdirs/platformdirs-2.3.0.ebuild30
-rw-r--r--dev-python/platformdirs/platformdirs-4.2.1.ebuild49
-rw-r--r--dev-python/platformdirs/platformdirs-4.2.2.ebuild54
6 files changed, 105 insertions, 87 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 0e76e925ac67..a12232193944 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,3 +1,2 @@
-DIST platformdirs-2.0.2.gh.tar.gz 11365 BLAKE2B 53257c69f26dde3a0031c991cd6b5c72b361084342617f5c0590007a11a1d7d6e3c925dd6a8d73d3553cf1cc1d2b9fdf74fd0553d6b8891ef6b21d64bc0e256f SHA512 7cdfbcb4e37f2b4b551f3d685a40780518f9ba9c333cef0664965abaca320a10f6e944f967c0b0ba2d00e80df04b0e1e03426e6d1291e28d8f64128f50ebc1fc
-DIST platformdirs-2.2.0.gh.tar.gz 17674 BLAKE2B 1b8e31033194f5682fb8c06be8268cc1ce6172b2bc9f0bfa0d376ab4387547c03c18d46e7c387eb2c36e5db42c09398c95d75cb32e4c5a59f0c7517e867aa1c1 SHA512 fbf4a6929543f5777576a258592e8065195e4d86d728f5c9b4065d1639d53b1c3c5de23c9d58282c291a7f600107af2de097ca2328f632927b9b773140590510
-DIST platformdirs-2.3.0.gh.tar.gz 18338 BLAKE2B c7d2b1b7ea65794507153b5c8d4d2e5a0668e4f9ef78024ab08c724e5cc5e91d0b6d7ec115a1ddab8a6fd7d34b4cb84cf3ebec64079d866344d2a7d18ca617e6 SHA512 3d20476d5064b6e300cddb5dcc9ba15346b1a8c3f5bfad869edda05cdd123a00a0c6c18b15af49a74f55fded5e11d69112b77239fe6f8f7da97c9a43ff442d8a
+DIST platformdirs-4.2.1.tar.gz 20398 BLAKE2B 6ae25a07afb0878a3c5347f4cc48e81117a5be42affe6b7873e1e62d9b4e8e63f380eb2a4062a472823c1d3e1eaaf499463ec93ca7e3c7c115c51a1c8fb10284 SHA512 c6c671022a74ba35610469f08e9a275daa19f0362a98208096fab147a77abfc96c12a0312fdf65668b3e457e0c06d938f141efec1217ef1a7598a77f65786130
+DIST platformdirs-4.2.2.tar.gz 20916 BLAKE2B d7c551a950118a127664b8210f33497760ce06381ac6a4ea098d1a1c60605507b5e2a9762d5f7d112332d3cebd63cb642b25e93a8b67dd2a1ee7cca189f3555f SHA512 e67aff332a6c84669d77a68e7d5546bfd14e08dcf61681b03447bf6381c0d981c63be0f87fd63bc99f0a51c92bf960902ded83ba8872801c14755ab163d45a0f
diff --git a/dev-python/platformdirs/platformdirs-2.0.2.ebuild b/dev-python/platformdirs/platformdirs-2.0.2.ebuild
deleted file mode 100644
index c57296e69f97..000000000000
--- a/dev-python/platformdirs/platformdirs-2.0.2.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
-HOMEPAGE="
- https://pypi.org/project/platformdirs/
- https://github.com/platformdirs/platformdirs/"
-SRC_URI="
- https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~mips ppc ppc64 ~riscv sparc x86"
-
-BDEPEND="
- test? ( dev-python/appdirs[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests unittest
diff --git a/dev-python/platformdirs/platformdirs-2.2.0.ebuild b/dev-python/platformdirs/platformdirs-2.2.0.ebuild
deleted file mode 100644
index ca2a1a338088..000000000000
--- a/dev-python/platformdirs/platformdirs-2.2.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
-HOMEPAGE="
- https://pypi.org/project/platformdirs/
- https://github.com/platformdirs/platformdirs/"
-SRC_URI="
- https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/platformdirs/platformdirs-2.3.0.ebuild b/dev-python/platformdirs/platformdirs-2.3.0.ebuild
deleted file mode 100644
index 39dce3345f62..000000000000
--- a/dev-python/platformdirs/platformdirs-2.3.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
-HOMEPAGE="
- https://pypi.org/project/platformdirs/
- https://github.com/platformdirs/platformdirs/"
-SRC_URI="
- https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/platformdirs/platformdirs-4.2.1.ebuild b/dev-python/platformdirs/platformdirs-4.2.1.ebuild
new file mode 100644
index 000000000000..1470f3d17320
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-4.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}
diff --git a/dev-python/platformdirs/platformdirs-4.2.2.ebuild b/dev-python/platformdirs/platformdirs-4.2.2.ebuild
new file mode 100644
index 000000000000..8bc5289f889b
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-4.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}