summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pplpy')
-rw-r--r--dev-python/pplpy/Manifest1
-rw-r--r--dev-python/pplpy/metadata.xml27
-rw-r--r--dev-python/pplpy/pplpy-0.8.10.ebuild50
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pplpy/Manifest b/dev-python/pplpy/Manifest
new file mode 100644
index 000000000000..f8d6a7f443cd
--- /dev/null
+++ b/dev-python/pplpy/Manifest
@@ -0,0 +1 @@
+DIST pplpy-0.8.10.tar.gz 64203 BLAKE2B b0735722a051ef33b7415528147a84a163ac49bf5d07e2f6599a7bbf004140abf5e6a09b7f0555ac57b55614a1c059bba20cc7ac7fe47a83f429e33d7f0dd1bc SHA512 982d36291cd0108786e47cb1ff73127ba2b2a619edc697e28360a87ace743e7fc6dd04e32aab38d41724d455de4861065f9ac3d409fd2f68114b07f4d1328c23
diff --git a/dev-python/pplpy/metadata.xml b/dev-python/pplpy/metadata.xml
new file mode 100644
index 000000000000..18bf8b9ca3a9
--- /dev/null
+++ b/dev-python/pplpy/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pplpy</remote-id>
+ <remote-id type="github">sagemath/pplpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pplpy/pplpy-0.8.10.ebuild b/dev-python/pplpy/pplpy-0.8.10.ebuild
new file mode 100644
index 000000000000..dd2eef3bce6e
--- /dev/null
+++ b/dev-python/pplpy/pplpy-0.8.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the Parma Polyhedra Library (PPL)"
+HOMEPAGE="
+ https://github.com/sagemath/pplpy/
+ https://pypi.org/project/pplpy/
+"
+
+# The file headers under ppl/ contain the "or later" bit
+LICENSE="GPL-3+"
+# API/ABI changes in point releases
+SLOT="0/${PV}"
+KEYWORDS="amd64"
+IUSE="doc"
+
+DEPEND="
+ dev-libs/ppl
+ dev-python/cysignals[${PYTHON_USEDEP}]
+ >=dev-python/gmpy-2.1.0_beta1[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile() {
+ # https://bugs.gentoo.org/927770
+ distutils-r1_python_compile -j1
+}
+
+python_compile_all() {
+ rm -r ppl || die
+ use doc && build_sphinx docs/source
+}
+
+python_test(){
+ "${EPYTHON}" tests/runtests.py || die
+}