summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/priority')
-rw-r--r--dev-python/priority/priority-1.3.0-r1.ebuild22
-rw-r--r--dev-python/priority/priority-2.0.0-r1.ebuild8
2 files changed, 23 insertions, 7 deletions
diff --git a/dev-python/priority/priority-1.3.0-r1.ebuild b/dev-python/priority/priority-1.3.0-r1.ebuild
index 4830c16b82dc..aa850d60259f 100644
--- a/dev-python/priority/priority-1.3.0-r1.ebuild
+++ b/dev-python/priority/priority-1.3.0-r1.ebuild
@@ -4,9 +4,10 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_TESTED=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" python3_12 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="A pure-Python implementation of the HTTP/2 priority tree"
HOMEPAGE="
@@ -14,14 +15,17 @@ HOMEPAGE="
https://github.com/python-hyper/priority/
https://pypi.org/project/priority/
"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
- test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
"
PATCHES=(
@@ -29,3 +33,13 @@ PATCHES=(
)
distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/python/cpython/issues/105042
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON} (xfail)"
+ return
+ fi
+
+ epytest
+}
diff --git a/dev-python/priority/priority-2.0.0-r1.ebuild b/dev-python/priority/priority-2.0.0-r1.ebuild
index f44bf4ebf0f7..cc2b87a3aa13 100644
--- a/dev-python/priority/priority-2.0.0-r1.ebuild
+++ b/dev-python/priority/priority-2.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -20,7 +20,9 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
- test? ( >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}] )
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest