summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prometheus_client/prometheus_client-0.4.2.ebuild')
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild b/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild
new file mode 100644
index 000000000000..b11eea0b1bae
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted[${PYTHON_USEDEP}] dev-python/twisted-web[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die
+}