summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild')
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild
new file mode 100644
index 000000000000..fe628251486f
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-3.0.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest