summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pulsectl/pulsectl-23.5.2.ebuild')
-rw-r--r--dev-python/pulsectl/pulsectl-23.5.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pulsectl/pulsectl-23.5.2.ebuild b/dev-python/pulsectl/pulsectl-23.5.2.ebuild
new file mode 100644
index 000000000000..a13a963b83ea
--- /dev/null
+++ b/dev-python/pulsectl/pulsectl-23.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+HOMEPAGE="
+ https://github.com/mk-fg/python-pulse-control/
+ https://pypi.org/project/pulsectl/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-sound/pulseaudio
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests unittest