summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild')
-rw-r--r--dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild b/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild
new file mode 100644
index 000000000000..f82e66ada297
--- /dev/null
+++ b/dev-python/py-cpuinfo/py-cpuinfo-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Get CPU info with pure Python 2 & 3"
+HOMEPAGE="https://github.com/workhorsy/py-cpuinfo
+ http://pypi.python.org/pypi/py-cpuinfo"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( ChangeLog )
+
+python_test() {
+ "${PYTHON}" test_suite.py -v || die
+}