summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyaml/pyaml-21.10.1.ebuild')
-rw-r--r--dev-python/pyaml/pyaml-21.10.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyaml/pyaml-21.10.1.ebuild b/dev-python/pyaml/pyaml-21.10.1.ebuild
new file mode 100644
index 000000000000..ad36eef3de6a
--- /dev/null
+++ b/dev-python/pyaml/pyaml-21.10.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYPI_PN="pyaml"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ppc64 ~riscv x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest