summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares/pycares-3.0.0_p20190709.ebuild')
-rw-r--r--dev-python/pycares/pycares-3.0.0_p20190709.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/pycares/pycares-3.0.0_p20190709.ebuild b/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
deleted file mode 100644
index 34d87e0a3df5..000000000000
--- a/dev-python/pycares/pycares-3.0.0_p20190709.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-EGIT_COMMIT=0c831407bc32c6e78a80c5b3d7865ba4c7ac26df
-MY_P=${PN}-${EGIT_COMMIT}
-
-DESCRIPTION="Python interface for c-ares"
-HOMEPAGE="https://github.com/saghul/pycares/"
-SRC_URI="https://github.com/saghul/pycares/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-# Tests fail with network-sandbox, since they try to resolve google.com
-RESTRICT="test"
-
-# uses bundled/patched c-ares
-RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- "${EPYTHON}" tests/tests.py -v || die
-}