summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest1
-rw-r--r--dev-python/pycares/metadata.xml11
-rw-r--r--dev-python/pycares/pycares-2.1.0.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
new file mode 100644
index 000000000000..b52a9b1cdc4c
--- /dev/null
+++ b/dev-python/pycares/Manifest
@@ -0,0 +1 @@
+DIST pycares-2.1.0.tar.gz 226838 SHA256 449ad785ecb594ae063c0c86537ef97513385117a2eb172f747ad2a29221e898 SHA512 189851a9488828eb41bd6adbefd14022ae8470bde98c1d1c21d67992acdf721e6a61c3d8d8b4f85fb420e1e0900c54e53893586d6f80cc822371260fc17e55c4 WHIRLPOOL 3c3274e122fcea0edee02e1d1719c5dfbf6d437860d2962da0c18e8e56314df149f5c40e1847f7b9ad58c10a594943419453f594017e8508d7d7acf6197c6d22
diff --git a/dev-python/pycares/metadata.xml b/dev-python/pycares/metadata.xml
new file mode 100644
index 000000000000..afce7552c1ca
--- /dev/null
+++ b/dev-python/pycares/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pycares</remote-id>
+ <remote-id type="github">saghul/pycares</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pycares/pycares-2.1.0.ebuild b/dev-python/pycares/pycares-2.1.0.ebuild
new file mode 100644
index 000000000000..23c452262334
--- /dev/null
+++ b/dev-python/pycares/pycares-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+# uses bundled/patched c-ares
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests/tests.py || die
+}