summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/Manifest1
-rw-r--r--dev-python/pycdio/metadata.xml11
-rw-r--r--dev-python/pycdio/pycdio-0.20-r1.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
new file mode 100644
index 000000000000..948ea6e7afd8
--- /dev/null
+++ b/dev-python/pycdio/Manifest
@@ -0,0 +1 @@
+DIST pycdio-0.20.tar.gz 197736 SHA256 24b4985b699fc4d12c2d49f7cb25a1ceb65d69278d18458f7b041579c71030d7 SHA512 b53a535440008dc637b31fd2cda22845c91b98e78c30f90c866af3b9bf7cb3faad39f0784b5063a39bd97bb18fc58c75ad0833d53421182d408c2889c491846b WHIRLPOOL 7722efc2398cdcf971ac7c62dc360514f64eb636a6c2c10ab86255e27802e99c4008613541bacf55e7fe20aa1431e1f44b60243722686d69fbc9df9fda6ff619
diff --git a/dev-python/pycdio/metadata.xml b/dev-python/pycdio/metadata.xml
new file mode 100644
index 000000000000..23ae40d39515
--- /dev/null
+++ b/dev-python/pycdio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">The pycdio (and libcdio) libraries encapsulate CD-ROM reading and
+ control. Python programs wishing to be oblivious of the OS- and
+ device-dependent properties of a CD-ROM can use this library.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pycdio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycdio/pycdio-0.20-r1.ebuild b/dev-python/pycdio/pycdio-0.20-r1.ebuild
new file mode 100644
index 000000000000..ed43e11220b3
--- /dev/null
+++ b/dev-python/pycdio/pycdio-0.20-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="http://savannah.gnu.org/projects/libcdio/ http://pypi.python.org/pypi/pycdio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/libcdio-0.90"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+RESTRICT="test" # currently tests fail
+
+python_prepare_all() {
+ # Remove obsolete sys.path and adjust 'data' paths in examples.
+ sed -i \
+ -e "s:^sys.path.insert.*::" \
+ -e "s:\.\./data:./data:g" \
+ example/*.py || die
+
+ # Disable failing tests.
+ sed -i -e "s/test_get_set/_&/" test/test-cdtext.py || die
+ sed -i -e "s/test_fs/_&/" test/test-isocopy.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all(){
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}