summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycson/pycson-0.8-r1.ebuild')
-rw-r--r--dev-python/pycson/pycson-0.8-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/pycson/pycson-0.8-r1.ebuild b/dev-python/pycson/pycson-0.8-r1.ebuild
index 330c7ca33866..8f32f7f9890d 100644
--- a/dev-python/pycson/pycson-0.8-r1.ebuild
+++ b/dev-python/pycson/pycson-0.8-r1.ebuild
@@ -2,13 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
+
DESCRIPTION="A python parser for the Coffeescript Object Notation (CSON)"
HOMEPAGE="https://github.com/avakar/pycson/"
SRC_URI="https://github.com/avakar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SLOT="0"
+
LICENSE="MIT"
+SLOT="0"
KEYWORDS="amd64 ~ppc ~riscv x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
RDEPEND="dev-python/speg"
+
+distutils_enable_tests pytest