summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycxx/pycxx-7.1.7-r1.ebuild')
-rw-r--r--dev-python/pycxx/pycxx-7.1.7-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild b/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
deleted file mode 100644
index cadfdbb9e765..000000000000
--- a/dev-python/pycxx/pycxx-7.1.7-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-PYTHON_COMPAT=( python3_{9..12} )
-# DISTUTILS_USE_PEP517=setuptools broken, installs files to /usr/CXX
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="doc examples"
-
-python_prepare_all() {
- # Without this, pysvn fails.
- # Src/Python3/cxxextensions.c: No such file or directory
- sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx} || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( Doc/. )
- if use examples ; then
- docinto examples
- dodoc -r Demo/Python{2,3}/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}