summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydecomp')
-rw-r--r--dev-python/pydecomp/Manifest1
-rw-r--r--dev-python/pydecomp/metadata.xml2
-rw-r--r--dev-python/pydecomp/pydecomp-0.1.ebuild44
-rw-r--r--dev-python/pydecomp/pydecomp-9999.ebuild11
4 files changed, 52 insertions, 6 deletions
diff --git a/dev-python/pydecomp/Manifest b/dev-python/pydecomp/Manifest
new file mode 100644
index 000000000000..de66e5345902
--- /dev/null
+++ b/dev-python/pydecomp/Manifest
@@ -0,0 +1 @@
+DIST pydecomp-0.1.tar.gz 8793 SHA256 4abff74b3d8814bb48be523d3d3ae91eb28e9d8e7fc887d909dcab09f857d6d6 SHA512 027925589da745bc34f87bf7845dd34f1feb61221bc48b3490e56145f3aef5856dbbce16ea36cc0a65e913b7fa8c042a914fbf9e1e3d82e26f98f8a6fbc6da5c WHIRLPOOL 7f5469291f9c19557adafe14d1dac894d5066391d759c2053f0c600b1bf2fae7543575586fda197af77be2c282a370814331ca07d376ca6d6b7495fdec234321
diff --git a/dev-python/pydecomp/metadata.xml b/dev-python/pydecomp/metadata.xml
index 116f970b0c60..adf744d32678 100644
--- a/dev-python/pydecomp/metadata.xml
+++ b/dev-python/pydecomp/metadata.xml
@@ -12,7 +12,7 @@
<longdescription>A python interface library for common compression ,
decompression and contents generation. It aims to create a simple,
easily extended and configurable common interface to various compressison
- routines. It can easily be extended with with custom compression,
+ routines. It can easily be extended with custom compression,
decompression, and contents definitions.
</longdescription>
<natural-name>pyDeComp</natural-name>
diff --git a/dev-python/pydecomp/pydecomp-0.1.ebuild b/dev-python/pydecomp/pydecomp-0.1.ebuild
new file mode 100644
index 000000000000..8282aa20d8c6
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1 python-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="git://github.com/dol-sen/pyDeComp.git"
+ inherit git-2
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is new software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyDeComp/issues"
+ einfo "I am also on IRC @ #gentoo-releng of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pydecomp/pydecomp-9999.ebuild b/dev-python/pydecomp/pydecomp-9999.ebuild
index a2395e87b04c..8282aa20d8c6 100644
--- a/dev-python/pydecomp/pydecomp-9999.ebuild
+++ b/dev-python/pydecomp/pydecomp-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1 python-r1
@@ -13,11 +13,12 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/dol-sen/pyDeComp.git"
inherit git-2
else
- SRC_URI="https://github.com/dol-sen/pyDeComp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/pyDeComp-${PV}"
fi
-DESCRIPTION="A python interface library for common compression, decompression and contents handling"
+DESCRIPTION="A python library of common (de)compression and contents handling"
HOMEPAGE="https://github.com/dol-sen/pyDeComp"
LICENSE="BSD"
@@ -30,7 +31,7 @@ python_install_all() {
pkg_postinst() {
einfo
- einfo "This is experimental software."
+ einfo "This is new software."
einfo "The API's it installs should be considered unstable"
einfo "and are subject to change."
einfo