summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydot/pydot-1.4.1.ebuild')
-rw-r--r--dev-python/pydot/pydot-1.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pydot/pydot-1.4.1.ebuild b/dev-python/pydot/pydot-1.4.1.ebuild
new file mode 100644
index 000000000000..b76e59073f32
--- /dev/null
+++ b/dev-python/pydot/pydot-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/erocarrera/pydot https://pypi.org/project/pydot/"
+# pypi releases don't include tests
+SRC_URI="https://github.com/erocarrera/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}