summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydot/pydot-1.4.2-r1.ebuild')
-rw-r--r--dev-python/pydot/pydot-1.4.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pydot/pydot-1.4.2-r1.ebuild b/dev-python/pydot/pydot-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..213049e89ea7
--- /dev/null
+++ b/dev-python/pydot/pydot-1.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/pydot/pydot https://pypi.org/project/pydot/"
+# pypi releases don't include tests
+SRC_URI="https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# See https://github.com/pydot/pydot/issues/277 for pyparsing dep
+RDEPEND="
+ <dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}