summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/pydot-1.4.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pydot/pydot-1.4.1.ebuild b/dev-python/pydot/pydot-1.4.1.ebuild
index b740101098cc..224ae09f8d9f 100644
--- a/dev-python/pydot/pydot-1.4.1.ebuild
+++ b/dev-python/pydot/pydot-1.4.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -20,9 +20,11 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/pyparsing-2.1.4[${PYTHON_USEDEP}]
media-gfx/graphviz"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )"
PATCHES=(
"${FILESDIR}"/${P}-unittest.patch