summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyelftools/pyelftools-0.24-r1.ebuild')
-rw-r--r--dev-python/pyelftools/pyelftools-0.24-r1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/pyelftools/pyelftools-0.24-r1.ebuild b/dev-python/pyelftools/pyelftools-0.24-r1.ebuild
deleted file mode 100644
index 6fe5be5f5353..000000000000
--- a/dev-python/pyelftools/pyelftools-0.24-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
-HOMEPAGE="https://pypi.org/project/pyelftools/ https://github.com/eliben/pyelftools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-python_test() {
- # readelf_tests often fails due to host `readelf` changing output format
- local t
- for t in all_unittests examples_test ; do
- "${PYTHON}" ./test/run_${t}.py || die "Tests fail with ${EPYTHON}"
- done
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}