summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyelftools/pyelftools-0.30.ebuild')
-rw-r--r--dev-python/pyelftools/pyelftools-0.30.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/pyelftools/pyelftools-0.30.ebuild b/dev-python/pyelftools/pyelftools-0.30.ebuild
deleted file mode 100644
index e8e2e4659be0..000000000000
--- a/dev-python/pyelftools/pyelftools-0.30.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
-HOMEPAGE="
- https://pypi.org/project/pyelftools/
- https://github.com/eliben/pyelftools/
-"
-# PyPI tarball lacks some test files
-SRC_URI="
- https://github.com/eliben/pyelftools/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-python_test() {
- # readelf_tests often fails due to host `readelf` changing output format
- "${EPYTHON}" test/run_all_unittests.py || die
- "${EPYTHON}" test/run_examples_test.py || die
-}