summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyenchant/pyenchant-3.2.1.ebuild')
-rw-r--r--dev-python/pyenchant/pyenchant-3.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyenchant/pyenchant-3.2.1.ebuild b/dev-python/pyenchant/pyenchant-3.2.1.ebuild
new file mode 100644
index 000000000000..d8534c8b1067
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-3.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="https://github.com/pyenchant/pyenchant
+ https://pypi.org/project/pyenchant/"
+SRC_URI="
+ https://github.com/pyenchant/pyenchant/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="app-text/enchant:*"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ )"
+
+distutils_enable_tests pytest