summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyformance/pyformance-0.4-r1.ebuild')
-rw-r--r--dev-python/pyformance/pyformance-0.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyformance/pyformance-0.4-r1.ebuild b/dev-python/pyformance/pyformance-0.4-r1.ebuild
new file mode 100644
index 000000000000..92b43e1f1e9a
--- /dev/null
+++ b/dev-python/pyformance/pyformance-0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~chutzpah/dist/python/pyformance-0.4-patches.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${WORKDIR}/pyformance-0.4-patches"
+)
+
+python_prepare() {
+ sed -e "s/find_packages()/find_packages(exclude=['tests'])/" \
+ -i setup.py || die
+}