summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index c9d0dab51af5..5f5c7f7efb9b 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,2 +1,3 @@
DIST pyftpdlib-1.5.7.tar.gz 196076 BLAKE2B 9400fb9ff5d8c0e904f07dabef72a07528bc43a5332ad26544f0e512c457a919e887e9f9af18b75cb7853f2e0b70993bc5a858438924320e738d4bc9e2e17090 SHA512 66ad5a1ab8fde26233250351f553cdc411303616d717c416cdce059f93c64e6ef64c7707103644583249b6aba22a9841994b38e731edc7997e95e266dbdbdc22
DIST pyftpdlib-1.5.7_p20230828.gh.tar.gz 257359 BLAKE2B 043f4be70b38b409548dd13739e9bcade7f489e9ce1a2e87ee4c631b76f484a0fa72b3ec45e7978cb38168823cdfc020adddc056a135644948415c5baab5ef33 SHA512 b0626559d2942abe63cf45a593f8da98d07124fca19e33c66bf86a9f24bffa842941cd419ad14f43b7ae337bdecb6628ce3184af991d3e87767a11f37eccdd63
+DIST pyftpdlib-1.5.8.tar.gz 201963 BLAKE2B 5a957c207dcdc7c8d66d6ed4176cd12db019cf3d5247233db057b5c266a4fbda5e6e1c0b8ccdf33b4c154400d5d7a5e9a62ab9244f7c74c03c2f912a2ac0eb2f SHA512 2d4c4beb40d604d41eeed51f690b805377e84e594bdbb5d67135f50e5696824ba24aa9ae53aecced9f6c1b7eb3ec7727d31b883f9bbb0d2c43802277b2ef2aa6
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild
new file mode 100644
index 000000000000..afb20a57db76
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}