summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyfuse3')
-rw-r--r--dev-python/pyfuse3/Manifest1
-rw-r--r--dev-python/pyfuse3/pyfuse3-3.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyfuse3/Manifest b/dev-python/pyfuse3/Manifest
index 542b6cee71f6..3e1db09c024e 100644
--- a/dev-python/pyfuse3/Manifest
+++ b/dev-python/pyfuse3/Manifest
@@ -1 +1,2 @@
DIST pyfuse3-3.2.3.tar.gz 512352 BLAKE2B 1b5826ea42a72fd5d688b4cd7617c2fd08a7f9b69381d52343e8891c90ba51f8c5c79a2b9c7c42944cd20493ea645a00a26e7c04cebec10322f71241b8b12df3 SHA512 2f35ea5e0f05af7184fe83458b976742f4f500d09098c68b71982e4b8c089485677bf1e704536e037d6f690fce3006a4fdb71697c68999ed412cc9d73aef8b13
+DIST pyfuse3-3.3.0.tar.gz 867765 BLAKE2B 29a871bbd4c82298231eac0c8d4b668a75a9ea748c3dd15f093a369770fbfe080620b6209c79ce934880757764c946c3216b558dcc63cd1d1a7ef03e124174c2 SHA512 b23116104fc78e9d6688e05f495a1cc48ff2c0af03a537c1f2743f84a596ba36b59e1ccba2e8272a0483c083479df91be2ccd49bd2e0cb160ff02a74ad623d18
diff --git a/dev-python/pyfuse3/pyfuse3-3.3.0.ebuild b/dev-python/pyfuse3/pyfuse3-3.3.0.ebuild
new file mode 100644
index 000000000000..0438bb0a3ef6
--- /dev/null
+++ b/dev-python/pyfuse3/pyfuse3-3.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python 3 bindings for libfuse 3 with asynchronous API"
+HOMEPAGE="
+ https://github.com/libfuse/pyfuse3/
+ https://pypi.org/project/pyfuse3/
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-fs/fuse:3
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/trio[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_configure() {
+ esetup.py build_cython
+}