summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygccxml/pygccxml-1.0.0.ebuild')
-rw-r--r--dev-python/pygccxml/pygccxml-1.0.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pygccxml/pygccxml-1.0.0.ebuild b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
index 2e4cae479cf1..0836d5058f5b 100644
--- a/dev-python/pygccxml/pygccxml-1.0.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -16,14 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
- app-arch/unzip"
+DEPEND="
+ app-arch/unzip
+ doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-cpp/gccxml-0.6"
python_compile_all() {
- if use doc; then
- esetup.py doc || die
- fi
+ use doc && esetup.py doc
}
python_test() {