summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyglet')
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-1.5.22.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index bb3223b2f591..d4fca3737768 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1 +1,2 @@
DIST pyglet-1.5.21.tar.gz 6516128 BLAKE2B ab7f23dc4ba48450f3da4efd30fadd089777f50b5392945636886192e89e230475f5bff9ba02cd166295423ed67f98b89fd186d18601504fe0f024c203a198c8 SHA512 3df0134dbfdeb15baae059bae489158273fd4797d5dc4da903ac2fdd58ae9e291e8d5371ebe545bd125a1670adfec84cb9d9f4f11841d594f3e4d38e5910ce2a
+DIST pyglet-1.5.22.tar.gz 6522926 BLAKE2B daeaabe414813ee850fe13bf6054919683017525ed545807da437f916105853108645d415efb4a0c8b6fdbadc7e1db241113a656ae031432bccd2fe7105bfa10 SHA512 d142bfa1cd533a4c10b93affc11b094e28cae56e0353bc56b5f5b993aedfb4ae3713f8e5ae7f9e9a646d59e76fbfe19e5b56442eb9595f2e994539c032a4c802
diff --git a/dev-python/pyglet/pyglet-1.5.22.ebuild b/dev-python/pyglet/pyglet-1.5.22.ebuild
new file mode 100644
index 000000000000..48457262adca
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.5.22.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://pyglet.org/"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+DOCS=( DESIGN NOTICE README.md RELEASE_NOTES )
+
+distutils_enable_tests pytest
+
+python_test() {
+ xdg_environment_reset
+
+ # Deselect openal test, can't open device in sandbox
+ local EPYTEST_DESELECT=(
+ tests/unit/media/test_listener.py::test_openal_listener
+ )
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ virtx epytest tests/unit
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}