summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments/pygments-2.14.0.ebuild')
-rw-r--r--dev-python/pygments/pygments-2.14.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pygments/pygments-2.14.0.ebuild b/dev-python/pygments/pygments-2.14.0.ebuild
deleted file mode 100644
index 6a612a3384d1..000000000000
--- a/dev-python/pygments/pygments-2.14.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 bash-completion-r1 pypi
-
-DESCRIPTION="Pygments is a syntax highlighting package written in Python"
-HOMEPAGE="
- https://pygments.org/
- https://github.com/pygments/pygments/
- https://pypi.org/project/Pygments/
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
- virtual/ttf-fonts
- )
-"
-
-distutils_enable_tests pytest
-
-src_install() {
- distutils-r1_src_install
- newbashcomp external/pygments.bashcomp pygmentize
-}