summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild')
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
index e634cade25b1..2398f2c70957 100644
--- a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
+++ b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
@@ -4,8 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-# py3.12 does not work, see https://github.com/seb-m/pyinotify/issues/204
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -13,14 +12,21 @@ inherit distutils-r1
DESCRIPTION="Python module used for monitoring filesystems events"
HOMEPAGE="
https://pypi.org/project/pyinotify/
- https://github.com/seb-m/pyinotify/"
-SRC_URI="https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+ https://github.com/seb-m/pyinotify/
+"
+SRC_URI="
+ https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples"
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
python_install_all() {
if use examples; then
dodoc -r python3/examples