summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/pyjwt-2.8.0.ebuild (renamed from dev-python/pyjwt/pyjwt-2.4.0.ebuild)18
2 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index dca287789b78..95bc4c64c3f3 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1 +1 @@
-DIST PyJWT-2.4.0.tar.gz 66327 BLAKE2B bc78ceebe3fedd4216420c34034de96dc6af488b4b50d20a03073753cfe94d059cda3e118f79cc3718253f56bb977b5b86543d1cd1ab7346a4095d0c2c6855b2 SHA512 6c60afe62f9341c0fd889be227cd9e44260bc88696a93d0c3398547e159001f04e402d207d2230641f0f3d37cfd7e6f9e50a42dadfb011d7087c32a864c792a4
+DIST PyJWT-2.8.0.tar.gz 78313 BLAKE2B b5031ec0ea672ef2dffc077aba6c781a20a7497257a16241841c0e0158017370581e3c9785d930772290c25fc9029e71a5d8744d999b135b29715a4f35720508 SHA512 74e74cf8c78494a9e51a2a186347361388031d5c0d0864df2a5d051621d9d31dff617ab1d7ebb4a829cc7d409d196e1bdb3b361ec888b6c14f1abea77544475e
diff --git a/dev-python/pyjwt/pyjwt-2.4.0.ebuild b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
index 5168c40ed0d3..96c1c8b218c8 100644
--- a/dev-python/pyjwt/pyjwt-2.4.0.ebuild
+++ b/dev-python/pyjwt/pyjwt-2.8.0.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYPI_NO_NORMALIZE=1
+PYPI_PN="PyJWT"
+PYTHON_COMPAT=( python3_{10..13} )
-inherit distutils-r1 optfeature
+inherit distutils-r1 optfeature pypi
-MY_PN="PyJWT"
DESCRIPTION="JSON Web Token implementation in Python"
HOMEPAGE="
https://github.com/jpadilla/pyjwt/
https://pypi.org/project/PyJWT/
"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S=${WORKDIR}/${MY_PN}-${PV}
LICENSE="MIT"
SLOT="0"
@@ -26,12 +25,17 @@ RDEPEND="
"
BDEPEND="
test? (
- >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.4.0[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_jwks_client.py::TestPyJWKClient::test_get_jwt_set_sslcontext_default
+)
+
pkg_postinst() {
optfeature "cryptography" dev-python/cryptography
}