summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pykka/pykka-3.0.2.ebuild')
-rw-r--r--dev-python/pykka/pykka-3.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pykka/pykka-3.0.2.ebuild b/dev-python/pykka/pykka-3.0.2.ebuild
new file mode 100644
index 000000000000..c2c6981f6e79
--- /dev/null
+++ b/dev-python/pykka/pykka-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://www.pykka.org/en/latest/
+ https://github.com/jodal/pykka/"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest