summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyls-spyder/pyls-spyder-0.1.1.ebuild')
-rw-r--r--dev-python/pyls-spyder/pyls-spyder-0.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyls-spyder/pyls-spyder-0.1.1.ebuild b/dev-python/pyls-spyder/pyls-spyder-0.1.1.ebuild
new file mode 100644
index 000000000000..37e8879ff2ea
--- /dev/null
+++ b/dev-python/pyls-spyder/pyls-spyder-0.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spyder extensions for the python language server"
+HOMEPAGE="https://github.com/spyder-ide/pyls-spyder
+ https://pypi.org/project/pyls-spyder/"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}-gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-language-server[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest