summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynacl/pynacl-1.1.1.ebuild')
-rw-r--r--dev-python/pynacl/pynacl-1.1.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pynacl/pynacl-1.1.1.ebuild b/dev-python/pynacl/pynacl-1.1.1.ebuild
deleted file mode 100644
index bc9c3cc8e614..000000000000
--- a/dev-python/pynacl/pynacl-1.1.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6})
-
-inherit distutils-r1
-
-MY_PN="PyNaCl"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.python.org/pypi/PyNaCl/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
- dev-libs/libsodium:0/18
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}] )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # For not using the bundled libsodium
- export SODIUM_INSTALL=system
- distutils-r1_python_prepare_all
-}