summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynacl/pynacl-1.3.0.ebuild')
-rw-r--r--dev-python/pynacl/pynacl-1.3.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pynacl/pynacl-1.3.0.ebuild b/dev-python/pynacl/pynacl-1.3.0.ebuild
deleted file mode 100644
index dfc8f7da7cdf..000000000000
--- a/dev-python/pynacl/pynacl-1.3.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6..9})
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to the Networking and Cryptography (NaCl) library"
-HOMEPAGE="https://github.com/pyca/pynacl/ https://pypi.org/project/PyNaCl/"
-SRC_URI="https://github.com/pyca/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/cffi-1.4.1[${PYTHON_USEDEP}]
- dev-libs/libsodium:0/23
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/hypothesis-3.27.0[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=( "${FILESDIR}/${P}-hypothesis-4.patch" )
-
-src_prepare() {
- # For not using the bundled libsodium
- export SODIUM_INSTALL=system
- distutils-r1_python_prepare_all
-}