summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyopengl/pyopengl-3.1.5.ebuild')
-rw-r--r--dev-python/pyopengl/pyopengl-3.1.5.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/pyopengl/pyopengl-3.1.5.ebuild b/dev-python/pyopengl/pyopengl-3.1.5.ebuild
deleted file mode 100644
index e371b19d84b7..000000000000
--- a/dev-python/pyopengl/pyopengl-3.1.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_REQ_USE="tk?"
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 virtualx
-
-MY_PN="PyOpenGL"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python OpenGL bindings"
-HOMEPAGE="http://pyopengl.sourceforge.net/ https://pypi.org/project/PyOpenGL/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-# mirror://sourceforge/pyopengl/${MY_P}.tar.gz" # broken mirror for this release
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="tk"
-
-RDEPEND="
- media-libs/freeglut
- virtual/opengl
- x11-libs/libXi
- x11-libs/libXmu
- tk? ( dev-tcltk/togl )
-"
-DEPEND="
- ${RDEPEND}
-"
-
-# The tests need an X server with the GLX extension. Software rendering
-# under Xvfb works but only with llvmpipe, not softpipe or swr.
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP},opengl,X]
- !prefix? (
- media-libs/mesa[llvm]
- x11-base/xorg-server[-minimal,xorg]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}