summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-fmt/pyproject-fmt-2.0.4.ebuild')
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.0.4.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.0.4.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.0.4.ebuild
deleted file mode 100644
index f3a2dd0fea03..000000000000
--- a/dev-python/pyproject-fmt/pyproject-fmt-2.0.4.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Format your pyproject.toml file"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-fmt/
- https://pypi.org/project/pyproject-fmt/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- ~dev-python/pyproject-fmt-rust-1.0.4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# tox is called as a subprocess, to get targets from tox.ini
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- dev-python/tox
- )
-"
-
-distutils_enable_tests pytest