summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest5
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild38
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.8.0.ebuild (renamed from dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild)24
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild36
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild36
5 files changed, 89 insertions, 50 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 8c253b7cba87..16de27a5879c 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,2 +1,3 @@
-DIST pyproject-fmt-0.9.1.gh.tar.gz 15434 BLAKE2B f9dd55b4106e875c80127ac60b3a54d4bdadf3555266a74cfd811ab96500879a7efb8eac71a041b2c33486bfcbc1f818a26a3ae3c50685f35cc3712691a85bb9 SHA512 ade87f43927c74e0328ffa8ac542bad204cc283d694f6921c40c86ae0a941ae50cc43fa4078ddcec28ff0d6003ac34a54232ea23d2820b5b2582482b22ac2a7e
-DIST pyproject-fmt-0.9.2.gh.tar.gz 15615 BLAKE2B 91912d350224fb2cbfd5f4e2310c10849dd0a1f43ac076059b521966d07526f9509cf87bba182cc4e9eb6b87c7c58c2972bb4f256bf63724e9d3b6c4fe9e67dd SHA512 3045381fc811fa8b8b7e845d9af5564d1969b73bfbb3e5a5c1953843754607cdbd809b829691d7195df73a1e136f68fbb3d3b66c783aa7c706b352e88d9b3f92
+DIST pyproject_fmt-1.8.0.tar.gz 16696 BLAKE2B 1614fd6da4bb7be818825138b69b826b7141ae0fcada4414daa54b1c883ec3bbdbe95377155869d0c393b1b9646b69ebb009fe47f1c530b1f1c9f02c8ba8f57d SHA512 0731ffbe514cf8788bf1cfcca506591fefce3b98b1c6d014a8e17825ab6c73edc4ad8e7214cd8f6fc9124ed2ff362d03b328d47e96a6246165b4dd9fdd68299f
+DIST pyproject_fmt-2.1.0.tar.gz 9012 BLAKE2B 5ddc95d9f5ef322f1895772d63a3d6a800172d57655f795d74a077628020ab54ee1a4ef52b3a317504567ce2a13b4c6cd229f7ee05dbcc5fecabb0762679f12e SHA512 00a9541c61ca1924a78a48736962df39e055cf61cd2a312dc0fd2c7efb247d504f7e747912d328e689de25049c944cc2b422dc6c74c1c1e910b6294bd2306944
+DIST pyproject_fmt-2.1.1.tar.gz 9015 BLAKE2B 40203bcae46203f4b0edba02290741788b5ea382595e0da4717a72a632e78bb4ce7d8ea3ae1d91129a9f51e2116b02ce65990419f878a4676aa152e4eb75fd67 SHA512 4ccb98d8a8fa6d1ee8f63a6e6fdfeab4411da267ec85da957fab92f593dfaf142daebd1cd9a398afe0ec18c135c365733d529204f042a57da7be9622f09dd7d1
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild
deleted file mode 100644
index a802c14c305f..000000000000
--- a/dev-python/pyproject-fmt/pyproject-fmt-0.9.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Format your pyproject.toml file"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-fmt/
- https://pypi.org/project/pyproject-fmt/
-"
-SRC_URI="
- https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/packaging-23[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.8.0.ebuild
index 18ae3f04023d..7da8128f9cf9 100644
--- a/dev-python/pyproject-fmt/pyproject-fmt-0.9.1.ebuild
+++ b/dev-python/pyproject-fmt/pyproject-fmt-1.8.0.ebuild
@@ -1,38 +1,42 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Format your pyproject.toml file"
HOMEPAGE="
https://github.com/tox-dev/pyproject-fmt/
https://pypi.org/project/pyproject-fmt/
"
-SRC_URI="
- https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- >=dev-python/packaging-23[${PYTHON_USEDEP}]
- >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
"
+# tox is called as a subprocess, to get targets from tox.ini
BDEPEND="
dev-python/hatch-vcs[${PYTHON_USEDEP}]
test? (
>=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
)
"
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+src_prepare() {
+ # upstream lower bounds are completely meaningless and copying them
+ # to the ebuild is a horrible waste of time
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild
new file mode 100644
index 000000000000..7027811e4f01
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ ~dev-python/pyproject-fmt-rust-1.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild
new file mode 100644
index 000000000000..eebff30a0ae0
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ ~dev-python/pyproject-fmt-rust-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest