summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy-exe/pypy-exe-7.3.2.ebuild')
-rw-r--r--dev-python/pypy-exe/pypy-exe-7.3.2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/pypy-exe/pypy-exe-7.3.2.ebuild b/dev-python/pypy-exe/pypy-exe-7.3.2.ebuild
index 730593111889..961ae14ae10f 100644
--- a/dev-python/pypy-exe/pypy-exe-7.3.2.ebuild
+++ b/dev-python/pypy-exe/pypy-exe-7.3.2.ebuild
@@ -31,10 +31,7 @@ BDEPEND="
!low-memory? (
|| (
dev-python/pypy
- (
- dev-lang/python:2.7
- dev-python/pycparser[python_targets_python2_7(-),python_single_target_python2_7(+)]
- )
+ dev-lang/python:2.7
)
)"
@@ -140,8 +137,16 @@ src_configure() {
"${EPYTHON}" --jit loop_longevity=300 )
fi
+ if [[ ${EPYTHON} != pypy ]]; then
+ # reuse bundled pycparser to avoid external dep
+ mkdir -p "${T}"/pymod/cffi || die
+ : > "${T}"/pymod/cffi/__init__.py || die
+ cp -r lib_pypy/cffi/_pycparser "${T}"/pymod/cffi/ || die
+ local -x PYTHONPATH=${T}/pymod:${PYTHONPATH}
+ fi
+
# translate into the C sources
- # we're going to make them ourselves since otherwise pypy does not
+ # we're going to build them ourselves since otherwise pypy does not
# free up the unneeded memory before spawning the compiler
set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
echo -e "\033[1m${@}\033[0m"