summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pypy/pypy-2.5.1.ebuild')
-rw-r--r--dev-python/pypy/pypy-2.5.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pypy/pypy-2.5.1.ebuild b/dev-python/pypy/pypy-2.5.1.ebuild
index c07de498ec7d..109ebeb41543 100644
--- a/dev-python/pypy/pypy-2.5.1.ebuild
+++ b/dev-python/pypy/pypy-2.5.1.ebuild
@@ -203,11 +203,13 @@ src_install() {
# Generate cffi cache
# Please keep in sync with pypy/tool/release/package.py!
- "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
"${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
if use gdbm; then
"${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
fi
+ if use ncurses; then
+ "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+ fi
if use sqlite; then
"${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
fi