summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyquery')
-rw-r--r--dev-python/pyquery/Manifest1
-rw-r--r--dev-python/pyquery/files/pyquery-1.4.0-network-tests.patch22
-rw-r--r--dev-python/pyquery/pyquery-1.4.0.ebuild41
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyquery/Manifest b/dev-python/pyquery/Manifest
index 5b721866db93..b462127aec00 100644
--- a/dev-python/pyquery/Manifest
+++ b/dev-python/pyquery/Manifest
@@ -1 +1,2 @@
DIST pyquery-1.2.13.tar.gz 44032 BLAKE2B df257c6116b3f8804627a0b4a6556445c644410acdf008fe9afd08136a0a7f47d66b99071cce61a1569853ec9c3c38d20ca66aec0950532e94949b36d4814c3e SHA512 39a2bfe6f1eaefb6d1a78f73e5bdb4d12a9e223b26f6aff0f979ceaa68005ab08e41bdf11fe808489d22e0506e558621982dc59fa2164cd1e3d8168b0ef8ceb6
+DIST pyquery-1.4.0.tar.gz 45215 BLAKE2B cb748c09524f6cc6b22c9712370da754495c31b159a44f02e9b5f00e4e94295d7259d224e63066297e6efd74f0b43a508a56d1df4f4150727cd261b959402e9a SHA512 523bc058fc93332b13840a7249bce5a449b0029f6434043a739a2f24abdd89efb314da8795f1b2be2d7e4464a8e4bdf6b061d768b895d0dd1630f44ee341f37f
diff --git a/dev-python/pyquery/files/pyquery-1.4.0-network-tests.patch b/dev-python/pyquery/files/pyquery-1.4.0-network-tests.patch
new file mode 100644
index 000000000000..337728794bb9
--- /dev/null
+++ b/dev-python/pyquery/files/pyquery-1.4.0-network-tests.patch
@@ -0,0 +1,22 @@
+Disable test that requires a network connection.
+
+--- a/tests/test_pyquery.py
++++ b/tests/test_pyquery.py
+@@ -613,10 +613,10 @@
+ self.s.shutdown()
+
+
+-class TestWebScrappingEncoding(TestCase):
+-
+- def test_get(self):
+- d = pq(u'http://ru.wikipedia.org/wiki/Заглавная_страница',
+- method='get')
+- print(d)
+- self.assertEqual(d('#pt-login').text(), u'Войти')
++#class TestWebScrappingEncoding(TestCase):
++#
++# def test_get(self):
++# d = pq(u'http://ru.wikipedia.org/wiki/Заглавная_страница',
++# method='get')
++# print(d)
++# self.assertEqual(d('#pt-login').text(), u'Войти')
diff --git a/dev-python/pyquery/pyquery-1.4.0.ebuild b/dev-python/pyquery/pyquery-1.4.0.ebuild
new file mode 100644
index 000000000000..9bf1439e941c
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
+ >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7') )"
+
+PATCHES=( "${FILESDIR}/${P}-network-tests.patch" )
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}