summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyquery')
-rw-r--r--dev-python/pyquery/Manifest1
-rw-r--r--dev-python/pyquery/files/pyquery-1.4.1-network-tests.patch20
-rw-r--r--dev-python/pyquery/files/pyquery-1.4.1-tests-pypy.patch20
-rw-r--r--dev-python/pyquery/pyquery-1.4.1.ebuild47
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pyquery/Manifest b/dev-python/pyquery/Manifest
index b462127aec00..49db60200e99 100644
--- a/dev-python/pyquery/Manifest
+++ b/dev-python/pyquery/Manifest
@@ -1,2 +1,3 @@
DIST pyquery-1.2.13.tar.gz 44032 BLAKE2B df257c6116b3f8804627a0b4a6556445c644410acdf008fe9afd08136a0a7f47d66b99071cce61a1569853ec9c3c38d20ca66aec0950532e94949b36d4814c3e SHA512 39a2bfe6f1eaefb6d1a78f73e5bdb4d12a9e223b26f6aff0f979ceaa68005ab08e41bdf11fe808489d22e0506e558621982dc59fa2164cd1e3d8168b0ef8ceb6
DIST pyquery-1.4.0.tar.gz 45215 BLAKE2B cb748c09524f6cc6b22c9712370da754495c31b159a44f02e9b5f00e4e94295d7259d224e63066297e6efd74f0b43a508a56d1df4f4150727cd261b959402e9a SHA512 523bc058fc93332b13840a7249bce5a449b0029f6434043a739a2f24abdd89efb314da8795f1b2be2d7e4464a8e4bdf6b061d768b895d0dd1630f44ee341f37f
+DIST pyquery-1.4.1.tar.gz 47983 BLAKE2B eb8d0ca59122734a4c715c33f40fd0b5fcc8edcabe9e41649ddf332feb1df603f8527a668aa7b9d78974b3d049e774355296644abd9b4d426d96e6e3c7a74065 SHA512 e2bfbbf51f99a408e9696a2b9c15f8875813847a10b5bd93c4c7a6886ac1b3ae6c7883ec4fb64e9bccab2127617843961e181044fe927f3c80c8ac363ed86141
diff --git a/dev-python/pyquery/files/pyquery-1.4.1-network-tests.patch b/dev-python/pyquery/files/pyquery-1.4.1-network-tests.patch
new file mode 100644
index 000000000000..37664689c0fd
--- /dev/null
+++ b/dev-python/pyquery/files/pyquery-1.4.1-network-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_pyquery.py b/tests/test_pyquery.py
+index ca38a83..d29b27b 100644
+--- a/tests/test_pyquery.py
++++ b/tests/test_pyquery.py
+@@ -6,6 +6,7 @@
+ import os
+ import sys
+ import time
++import unittest
+ from lxml import etree
+ from pyquery.pyquery import PyQuery as pq, no_default
+ from pyquery.openers import HAS_REQUEST
+@@ -889,6 +890,7 @@ class TestWebScrapping(TestCase):
+
+ class TestWebScrappingEncoding(TestCase):
+
++ @unittest.skip("needs internet")
+ def test_get(self):
+ d = pq(u'http://ru.wikipedia.org/wiki/Заглавная_страница',
+ method='get')
diff --git a/dev-python/pyquery/files/pyquery-1.4.1-tests-pypy.patch b/dev-python/pyquery/files/pyquery-1.4.1-tests-pypy.patch
new file mode 100644
index 000000000000..f5f160a138de
--- /dev/null
+++ b/dev-python/pyquery/files/pyquery-1.4.1-tests-pypy.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_pyquery.py b/tests/test_pyquery.py
+index d29b27b..e6a9230 100644
+--- a/tests/test_pyquery.py
++++ b/tests/test_pyquery.py
+@@ -7,6 +7,7 @@ import os
+ import sys
+ import time
+ import unittest
++import platform
+ from lxml import etree
+ from pyquery.pyquery import PyQuery as pq, no_default
+ from pyquery.openers import HAS_REQUEST
+@@ -33,6 +34,7 @@ path_to_invalid_file = os.path.join(dirname, 'invalid.xml')
+
+ class TestUnicode(TestCase):
+
++ @unittest.skipIf(sys.hexversion > 0x3000000 and 'pypy' in platform.python_implementation().lower(), "broken on pypy3")
+ def test_unicode(self):
+ xml = pq(u"<html><p>é</p></html>")
+ self.assertEqual(type(xml.html()), text_type)
diff --git a/dev-python/pyquery/pyquery-1.4.1.ebuild b/dev-python/pyquery/pyquery-1.4.1.ebuild
new file mode 100644
index 000000000000..ddcfe184a05d
--- /dev/null
+++ b/dev-python/pyquery/pyquery-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A jQuery-like library for python"
+HOMEPAGE="https://github.com/gawel/pyquery"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/lxml-2.1[${PYTHON_USEDEP}]
+ >dev-python/cssselect-0.7.9[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.1.9[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/webtest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' 'python2_7')
+ )"
+
+RESTRICT+=" !test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pyquery-1.4.1-network-tests.patch"
+ "${FILESDIR}/pyquery-1.4.1-tests-pypy.patch"
+)
+
+python_test() {
+ # The suite, it appears, requires this hard setting of PYTHONPATH!
+ PYTHONPATH=. nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Support for BeautifulSoup3 as a parser backend" dev-python/beautifulsoup
+}