summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-2.0.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.0.ebuild b/dev-python/pyrqlite/pyrqlite-2.0.ebuild
new file mode 100644
index 000000000000..3f58fe140144
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="Python client for rqlite"
+EGIT_REPO_URI="https://github.com/rqlite/pyrqlite.git"
+HOMEPAGE="${EGIT_REPO_URI%.git}/"
+SRC_URI="${EGIT_REPO_URI%.git}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die "tests failed"
+ esetup.py lint -f text -E || die "pylint failed"
+}