summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscard/pyscard-1.9.9.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-1.9.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-1.9.9.ebuild b/dev-python/pyscard/pyscard-1.9.9.ebuild
new file mode 100644
index 000000000000..5c90cee6a2f5
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="${PYTHON_DEP}
+ sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${PYTHON_DEP}
+ dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}