summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyscard/pyscard-1.9.9.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-1.9.9.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/pyscard/pyscard-1.9.9.ebuild b/dev-python/pyscard/pyscard-1.9.9.ebuild
deleted file mode 100644
index 6964fbdc2609..000000000000
--- a/dev-python/pyscard/pyscard-1.9.9.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Smart cards support in python"
-HOMEPAGE="https://pyscard.sourceforge.io/
- https://github.com/LudovicRousseau/pyscard
- https://pypi.org/project/pyscard/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-
-RDEPEND="${PYTHON_DEP}
- sys-apps/pcsc-lite"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${PYTHON_DEP}
- dev-lang/swig"
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- optfeature "Gui support" dev-python/wxpython
- optfeature "Support of remote readers with Pyro" dev-python/pyro
-}