summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild')
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
index c3be9a1f2c6a..1b1087b8edf8 100644
--- a/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-4.1.0.ebuild
@@ -30,5 +30,9 @@ src_test() {
# terminal_reporter test needs exact wrapping
local -x COLUMNS=80
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
distutils-r1_src_test
}