summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest3
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild40
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild (renamed from dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild)22
3 files changed, 14 insertions, 51 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index d15d7edff11a..9e28e80cea5b 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,2 +1 @@
-DIST pytest-bdd-5.0.0.gh.tar.gz 61174 BLAKE2B 6dd1d53614226d3515b0f61f71822363b559aa45789bab7f3416c75e603e87a1fe48627f36862f44bfa7ac6ec5023ad8afde6054ec67fc9a2e756be7de729fd1 SHA512 827e57d410b05207b6c646062ddb54b677e22441311820d3bd406df202b6e9344dedf59cd4868e89cfbf8606fe3f15559e4cc3958d100e4fa74f9b864e6faada
-DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
+DIST pytest-bdd-7.1.2.gh.tar.gz 81260 BLAKE2B 5120a79a5c085976f379afbd4ae7bc68c0d07a8517b6653bb2c94407b9964cd3adcfc92e8abc31cb658caa5c108e0590913c13cbcc408021841b91dbf52b8124 SHA512 7630b119649502e36d7ae2b6027c11b667513eab451511104076617e50de1456ee4b2ff128254ac0db630556258704e21e2a5e73ce9afc20ed403d0186c0a226
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild
deleted file mode 100644
index 7682168ff49b..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/glob2[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}
diff --git a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild
index edc44c97450b..51e3319ece59 100644
--- a/dev-python/pytest-bdd/pytest-bdd-5.0.0-r1.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-7.1.2.ebuild
@@ -1,27 +1,31 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="https://pytest-bdd.readthedocs.io/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
+KEYWORDS="amd64 arm64 ~x86"
RDEPEND="
- dev-python/glob2[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
dev-python/parse[${PYTHON_USEDEP}]
dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/packaging[${PYTHON_USEDEP}]"
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest