summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-check/pytest-check-1.0.4.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-1.0.4.ebuild b/dev-python/pytest-check/pytest-check-1.0.4.ebuild
new file mode 100644
index 000000000000..08ebac53b79f
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="https://github.com/okken/pytest-check https://pypi.org/project/pytest_check/"
+SRC_URI="
+ https://github.com/okken/pytest-check/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pytest-6[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/flit_core[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ default
+ mv src/pytest_check pytest_check
+}