summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/pytest-django-2.9.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/pytest-django/pytest-django-2.9.1.ebuild b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
index 4c225165f6d6..51e676ea4872 100644
--- a/dev-python/pytest-django/pytest-django-2.9.1.ebuild
+++ b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,6 +25,13 @@ DEPEND="${RDEPEND}
# https://github.com/pytest-dev/pytest-django/issues/290
RESTRICT=test
+src_prepare() {
+ sed \
+ -e '/setuptools_scm/s:==1.8.0::g' \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
PYTEST_PLUGINS=${PN/-/_} \
py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die