summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild')
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
new file mode 100644
index 000000000000..3023f8be88d9
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"