summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-golden/pytest-golden-0.2.2.ebuild')
-rw-r--r--dev-python/pytest-golden/pytest-golden-0.2.2.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild b/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
index 3087ff87091d..343ed09d482b 100644
--- a/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
+++ b/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
@@ -4,17 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Plugin for pytest that offloads expected outputs to data files"
HOMEPAGE="
- https://github.com/oprypin/pytest-golden
+ https://github.com/oprypin/pytest-golden/
https://pypi.org/project/pytest-golden/
"
# No tests in PyPI tarballs
-SRC_URI="https://github.com/oprypin/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/oprypin/pytest-golden/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -29,3 +32,9 @@ RDEPEND="
"
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_golden.plugin
+ epytest -x
+}