summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-golden/pytest-golden-0.2.2.ebuild')
-rw-r--r--dev-python/pytest-golden/pytest-golden-0.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild b/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
new file mode 100644
index 000000000000..3ad9c0b434be
--- /dev/null
+++ b/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for pytest that offloads expected outputs to data files"
+HOMEPAGE="
+ https://github.com/oprypin/pytest-golden
+ https://pypi.org/project/pytest-golden/
+"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/oprypin/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/atomicwrites-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.2[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16.12[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-1.0[${PYTHON_USEDEP}]
+ >=dev-python/testfixtures-6.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest