summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild')
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
new file mode 100644
index 000000000000..d19d19f131bd
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest